What’s Vulnerable › Vulnerabilities
CVE-2024-45808: Malicious log injection via access logs in envoy
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-20 · updated 2026-06-17
- Weakness: CWE-117
Description
Envoy is a cloud-native high-performance edge/middle/service proxy. A vulnerability has been identified in Envoy that allows malicious attackers to inject unexpected content into access logs. This is achieved by exploiting the lack of validation for the `REQUESTED_SERVER_NAME` field for access loggers. This issue has been addressed in versions 1.31.2, 1.30.6, 1.29.9, and 1.28.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- envoyproxy envoy: before 1.28.7; from 1.29.0 before 1.29.9; from 1.30.0 before 1.30.6; from 1.31.0 before 1.31.2 — fixed in 1.28.7, 1.29.9, 1.30.6, 1.31.2
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.28.7, 1.29.9, 1.30.6, 1.31.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45808 or the next vulnerability affects your stack