What’s Vulnerable › Vulnerabilities
CVE-2024-45848
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-12 · updated 2026-06-17
- Weakness: CWE-95
Description
An arbitrary code execution vulnerability exists in versions 23.12.4.0 up to 24.7.4.1 of the MindsDB platform, when the ChromaDB integration is installed on the server. If a specially crafted ‘INSERT’ query containing Python code is run against a database created with the ChromaDB engine, the code will be passed to an eval function and executed on the server.
Affected products
- mindsdb: from 23.12.4.0 before 24.7.4.1 — fixed in 24.7.4.1
How to fix
Upgrade to a fixed version: mindsdb 24.7.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45848 or the next vulnerability affects your stack