What’s Vulnerable › Vulnerabilities
CVE-2024-45944
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-18 · updated 2026-06-17
Description
In J2eeFAST <=2.7, the backend function has unsafe filtering, which allows an attacker to trigger certain sensitive functions resulting in arbitrary code execution.
Affected products
- Dromara J2eeFAST: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: Dromara J2eeFAST 2.6.0. Check the vendor advisory for mitigations.
References
- https://gitee.com/dromara/J2EEFAST
- https://github.com/dromara/J2EEFAST
- https://github.com/lazy-forever/CVE-Reference/tree/main/2024/45944
Get alerted when CVE-2024-45944 or the next vulnerability affects your stack