What’s Vulnerable › Vulnerabilities
CVE-2024-4596: Kimai Session information disclosure
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-07 · updated 2026-06-17
- Weakness: CWE-200
Description
A vulnerability was found in Kimai up to 2.15.0 and classified as problematic. Affected by this issue is some unknown functionality of the component Session Handler. The manipulation of the argument PHPSESSIONID leads to information disclosure. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 2.16.0 is able to address this issue. It is recommended to upgrade the affected component. VDB-263318 is the identifier assigned to this vulnerability.
Affected products
- kimai: before 2.16.0 — fixed in 2.16.0
How to fix
Upgrade to a fixed version: kimai 2.16.0. Check the vendor advisory for mitigations.
References
- https://github.com/kimai/kimai/releases/tag/2.16.0
- https://vuldb.com/?ctiid.263318
- https://vuldb.com/?id.263318
- https://vuldb.com/?submit.328639
- https://github.com/kimai/kimai/releases/tag/2.16.0
- https://vuldb.com/?ctiid.263318
- https://vuldb.com/?id.263318
- https://vuldb.com/?submit.328639
Get alerted when CVE-2024-4596 or the next vulnerability affects your stack