What’s Vulnerable › Vulnerabilities

CVE-2024-4597: Cross-Site Request Forgery (CSRF) in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions from 16.7 before 16.9.7, all versions starting from 16.10 before 16.10.5, all versions starting from 16.11 before 16.11.2. An attacker could force a user with an active SAML session to approve an MR via CSRF.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.10.5, 16.11.2, 16.9.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-4597 or the next vulnerability affects your stack