What’s Vulnerable › Vulnerabilities
CVE-2024-4602: Embed Peertube Playlist < 1.10 - Editor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Embed Peertube Playlist WordPress plugin before 1.10 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Embed Peertube Playlist: before 1.10 — fixed in 1.10
How to fix
Upgrade to a fixed version: Embed Peertube Playlist 1.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bc15bac7-8241-472a-a7c1-58070714501d/
- https://wpscan.com/vulnerability/bc15bac7-8241-472a-a7c1-58070714501d/
Get alerted when CVE-2024-4602 or the next vulnerability affects your stack