What’s Vulnerable › Vulnerabilities
CVE-2024-46060
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-17 · updated 2026-09-26
- Weakness: CWE-77
Description
Anaconda3 macOS installers before 2024.06-1 contain a local privilege escalation vulnerability when installed outside the user's home directory. During installation, world-writable files are created and executed with root privileges. This allows a local low-privileged user to inject arbitrary commands, leading to code execution as the root user.
Affected products
- Anaconda3: before 2024.06-1 — fixed in 2024.06-1
How to fix
Upgrade to a fixed version: Anaconda3 2024.06-1. Check the vendor advisory for mitigations.
References
- https://m8sec.dev/blog/privilege-escalation-macos-pkg-installers/
- https://www.anaconda.com/docs/getting-started/anaconda/release/2024.x#anaconda-2024-06-1
Get alerted when CVE-2024-46060 or the next vulnerability affects your stack