What’s Vulnerable › Vulnerabilities
CVE-2024-46062
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-17 · updated 2026-10-27
- Weakness: CWE-77
Description
Miniconda3 macOS installers before 23.11.0-1 contain a local privilege escalation vulnerability when installed outside the user's home directory. During installation, world-writable files are created and executed with root privileges. This flaw allows a local low-privileged user to inject arbitrary commands, leading to code execution as the root user.
Affected products
- conda Miniconda3: before 23.11.0-1 — fixed in 23.11.0-1
How to fix
Upgrade to a fixed version: conda Miniconda3 23.11.0-1. Check the vendor advisory for mitigations.
References
- https://m8sec.dev/blog/privilege-escalation-macos-pkg-installers/
- https://www.anaconda.com/docs/getting-started/miniconda/release/23.x#miniconda-23-11-0-1
Get alerted when CVE-2024-46062 or the next vulnerability affects your stack