What’s Vulnerable › Vulnerabilities
CVE-2024-4611: AppPresser <= 4.3.2 - Improper Missing Encryption Exception Handling to Authentication Bypass
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-29 · updated 2026-06-17
- Weakness: CWE-703
Description
The AppPresser plugin for WordPress is vulnerable to improper missing encryption exception handling on the 'decrypt_value' and on the 'doCookieAuth' functions in all versions up to, and including, 4.3.2. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they previously used the login via the plugin API. This can only be exploited if the 'openssl' php extension is not loaded on the server.
Affected products
- scottopolis AppPresser – Mobile App Framework: before 4.4.0 — fixed in 4.4.0
How to fix
Upgrade to a fixed version: scottopolis AppPresser – Mobile App Framework 4.4.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/apppresser/trunk/inc/AppPresser_Theme_Switcher.php?rev=2456516#L133
- https://plugins.trac.wordpress.org/browser/apppresser/trunk/inc/AppPresser_Theme_Switcher.php?rev=2456516#L167
- https://plugins.trac.wordpress.org/browser/apppresser/trunk/inc/AppPresser_User.php?rev=2789173#L40
- https://plugins.trac.wordpress.org/changeset/3093975/apppresser
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d1498fdf-9d5e-4277-92be-469d6646864b?source=cve
- https://plugins.trac.wordpress.org/browser/apppresser/trunk/inc/AppPresser_Theme_Switcher.php?rev=2456516#L133
- https://plugins.trac.wordpress.org/browser/apppresser/trunk/inc/AppPresser_Theme_Switcher.php?rev=2456516#L167
- https://plugins.trac.wordpress.org/browser/apppresser/trunk/inc/AppPresser_User.php?rev=2789173#L40
- https://plugins.trac.wordpress.org/changeset/3093975/apppresser
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d1498fdf-9d5e-4277-92be-469d6646864b?source=cve
Get alerted when CVE-2024-4611 or the next vulnerability affects your stack