What’s Vulnerable › Vulnerabilities
CVE-2024-4619: Elementor Website Builder – More than Just a Page Builder <= 3.21.5 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Elementor Website Builder – More than Just a Page Builder plugin for WordPress is vulnerable to DOM-Based Stored Cross-Site Scripting via the ‘hover_animation’ parameter in versions up to, and including, 3.21.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Elementor Website Builder: before 3.21.5 — fixed in 3.21.5
How to fix
Upgrade to a fixed version: Elementor Website Builder 3.21.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/elementor/trunk/includes/widgets/image-box.php#L696
- https://plugins.trac.wordpress.org/changeset/3089420
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c7e1028e-e04b-46c4-b574-889d9fc1069d?source=cve
- https://plugins.trac.wordpress.org/browser/elementor/trunk/includes/widgets/image-box.php#L696
- https://plugins.trac.wordpress.org/changeset/3089420
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c7e1028e-e04b-46c4-b574-889d9fc1069d?source=cve
Get alerted when CVE-2024-4619 or the next vulnerability affects your stack