What’s Vulnerable › Vulnerabilities
CVE-2024-4634: Elementor Header & Footer Builder <= 1.6.28 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Elementor Header & Footer Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘hfe_svg_mime_types’ function in versions up to, and including, 1.6.28 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- brainstormforce Ultimate Addons for Elementor: before 1.6.29 — fixed in 1.6.29
How to fix
Upgrade to a fixed version: brainstormforce Ultimate Addons for Elementor 1.6.29. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/header-footer-elementor/tags/1.6.28/inc/widgets-manager/class-widgets-loader.php#L156
- https://plugins.trac.wordpress.org/changeset/3086402/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f44bb823-bbf3-413b-82b5-a351609270bf?source=cve
- https://plugins.trac.wordpress.org/browser/header-footer-elementor/tags/1.6.28/inc/widgets-manager/class-widgets-loader.php#L156
- https://plugins.trac.wordpress.org/changeset/3086402/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f44bb823-bbf3-413b-82b5-a351609270bf?source=cve
Get alerted when CVE-2024-4634 or the next vulnerability affects your stack