What’s Vulnerable › Vulnerabilities
CVE-2024-46506
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 62.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-13 · updated 2026-06-17
- Weakness: CWE-306
Description
NetAlertX 23.01.14 through 24.x before 24.10.12 allows unauthenticated command injection via settings update because function=savesettings lacks an authentication requirement, as exploited in the wild in May 2025. This is related to settings.php and util.php.
Affected products
- NetAlertX: from 23.01.14 before 24.10.12 — fixed in 24.10.12
How to fix
Upgrade to a fixed version: NetAlertX 24.10.12. Check the vendor advisory for mitigations.
References
- https://rhinosecuritylabs.com/research/cve-2024-46506-rce-in-netalertx/
- https://rhinosecuritylabs.com/research/cve-2024-46506-rce-in-netalertx/
Get alerted when CVE-2024-46506 or the next vulnerability affects your stack