What’s Vulnerable › Vulnerabilities
CVE-2024-46544: Apache Tomcat Connectors: mod_jk: local users can view and modify configuration
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-23 · updated 2026-06-17
- Weakness: CWE-276
Description
Incorrect Default Permissions vulnerability in Apache Tomcat Connectors allows local users to view and modify shared memory containing mod_jk configuration which may lead to information disclosure and/or denial of service. This issue affects Apache Tomcat Connectors: from 1.2.9-beta through 1.2.49. Only mod_jk on Unix like systems is affected. Neither the ISAPI redirector nor mod_jk on Windows is affected. Users are recommended to upgrade to version 1.2.50, which fixes the issue.
Affected products
- Apache Tomcat Connectors: from 1.2.9 before 1.2.50 — fixed in 1.2.50
- Debian Linux: 11.0
How to fix
Upgrade to a fixed version: Apache Tomcat Connectors 1.2.50. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/q1gp7cc38hs1r8gj8gfnopwznd5fpr4d
- http://www.openwall.com/lists/oss-security/2024/09/23/1
- https://lists.debian.org/debian-lts-announce/2024/10/msg00010.html
Get alerted when CVE-2024-46544 or the next vulnerability affects your stack