What’s Vulnerable › Vulnerabilities

CVE-2024-4660: Missing Authorization in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 11.2 before 17.1.7, all versions starting from 17.2 before 17.2.5, all versions starting from 17.3 before 17.3.2. It was possible for a guest to read the source code of a private project by using group templates.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.1.7, 17.2.5, 17.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-4660 or the next vulnerability affects your stack