What’s Vulnerable › Vulnerabilities
CVE-2024-4664: WP Chat App < 3.6.5 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Chat App WordPress plugin before 3.6.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admins to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed.
Affected products
- ninjateam WP Chat App: before 3.6.5 — fixed in 3.6.5
How to fix
Upgrade to a fixed version: ninjateam WP Chat App 3.6.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/46ada0b4-f3cd-44fb-a568-3345e639bdb6/
- https://wpscan.com/vulnerability/46ada0b4-f3cd-44fb-a568-3345e639bdb6/
Get alerted when CVE-2024-4664 or the next vulnerability affects your stack