What’s Vulnerable › Vulnerabilities
CVE-2024-46725: drm/amdgpu: Fix out-of-bounds write warning
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-18 · updated 2026-08-04
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amdgpu: Fix out-of-bounds write warning Check the ring type value to fix the out-of-bounds write warning
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.10.0 before 5.10.226; from 5.15 before 5.15.167; from 6.1.0 before 6.1.109; from 6.6 before 6.6.50; from 6.10 before 6.10.9 — fixed in 5.10.226, 5.15.167, 6.1.109, 6.10.9, 6.6.50
How to fix
Upgrade to a fixed version: Linux kernel 5.10.226, 5.15.167, 6.1.109, 6.10.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/130bee397b9cd52006145c87a456fd8719390cb5
- https://git.kernel.org/stable/c/919f9bf9997b8dcdc132485ea96121e7d15555f9
- https://git.kernel.org/stable/c/a60d1f7ff62e453dde2d3b4907e178954d199844
- https://git.kernel.org/stable/c/be1684930f5262a622d40ce7a6f1423530d87f89
- https://git.kernel.org/stable/c/c253b87c7c37ec40a2e0c84e4a6b636ba5cd66b2
- https://git.kernel.org/stable/c/cf2db220b38301b6486a0f11da24a0f317de558c
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-46725 or the next vulnerability affects your stack