What’s Vulnerable › Vulnerabilities
CVE-2024-46728: drm/amd/display: Check index for aux_rd_interval before using
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-18 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amd/display: Check index for aux_rd_interval before using aux_rd_interval has size of 7 and should be checked. This fixes 3 OVERRUN and 1 INTEGER_OVERFLOW issues reported by Coverity.
Affected products
- Linux kernel: before 6.6.50; from 6.7 before 6.10.9 — fixed in 6.10.9, 6.6.50
How to fix
Upgrade to a fixed version: Linux kernel 6.10.9, 6.6.50. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/48e0b68e2360b16edf2a0bae05c0051c00fbb48a
- https://git.kernel.org/stable/c/6c588e9350dd7a9fb97a56fe74852c9ecc44450c
- https://git.kernel.org/stable/c/9ba2ea6337b4f159aecb177555a6a81da92d302e
Get alerted when CVE-2024-46728 or the next vulnerability affects your stack