What’s Vulnerable › Vulnerabilities
CVE-2024-46731: drm/amd/pm: fix the Out-of-bounds read warning
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-18 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amd/pm: fix the Out-of-bounds read warning using index i - 1U may beyond element index for mc_data[] when i = 0.
Affected products
- Linux kernel: before 5.10.226; from 5.11 before 5.15.167; from 5.16 before 6.1.109; from 6.2 before 6.6.50; from 6.7 before 6.10.9 — fixed in 5.10.226, 5.15.167, 6.1.109, 6.10.9, 6.6.50
How to fix
Upgrade to a fixed version: Linux kernel 5.10.226, 5.15.167, 6.1.109, 6.10.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/12c6967428a099bbba9dfd247bb4322a984fcc0b
- https://git.kernel.org/stable/c/20c6373a6be93039f9d66029bb1e21038a060be1
- https://git.kernel.org/stable/c/3317966efcdc5101e93db21514b68917e7eb34ea
- https://git.kernel.org/stable/c/38e32a0d837443c91c4b615a067b976cfb925376
- https://git.kernel.org/stable/c/d83fb9f9f63e9a120bf405b078f829f0b2e58934
- https://git.kernel.org/stable/c/f1e261ced9bcad772a45a2fcdf413c3490e87299
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-46731 or the next vulnerability affects your stack