What’s Vulnerable › Vulnerabilities
CVE-2024-46810: drm/bridge: tc358767: Check if fully initialized before signalling HPD event via IRQ
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: drm/bridge: tc358767: Check if fully initialized before signalling HPD event via IRQ Make sure the connector is fully initialized before signalling any HPD events via drm_kms_helper_hotplug_event(), otherwise this may lead to NULL pointer dereference.
Affected products
- Linux kernel: before 5.15.167; from 5.16 before 6.1.109; from 6.2 before 6.6.50; from 6.7 before 6.10.9 — fixed in 5.15.167, 6.1.109, 6.10.9, 6.6.50
How to fix
Upgrade to a fixed version: Linux kernel 5.15.167, 6.1.109, 6.10.9, 6.6.50. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/162e48cb1d84c2c966b649b8ac5c9d4f75f6d44f
- https://git.kernel.org/stable/c/1fb13693953737783b424aa4712f0a27a9eaf5a8
- https://git.kernel.org/stable/c/9d567126474e68f959b2c2543c375f3bb32e948a
- https://git.kernel.org/stable/c/adc5674c23b8191e596ed0dbaa9600265ac896a8
- https://git.kernel.org/stable/c/e1b121f21bbc56a6ae035aa5b77daac62bfb9be5
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-46810 or the next vulnerability affects your stack