What’s Vulnerable › Vulnerabilities
CVE-2024-46811: drm/amd/display: Fix index may exceed array range within fpu_update_bw_bounding_box
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-10-30
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amd/display: Fix index may exceed array range within fpu_update_bw_bounding_box [Why] Coverity reports OVERRUN warning. soc.num_states could be 40. But array range of bw_params->clk_table.entries is 8. [How] Assert if soc.num_states greater than 8.
Affected products
- Linux kernel: before 6.6.50; from 6.7 before 6.10.9 — fixed in 6.6.50, 6.10.9
- Linux: 4.15 — fixed in 6.11
How to fix
Upgrade to a fixed version: Linux kernel 6.6.50, 6.10.9; Linux 6.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/188fd1616ec43033cedbe343b6579e9921e2d898
- https://git.kernel.org/stable/c/4003bac784380fed1f94f197350567eaa73a409d
- https://git.kernel.org/stable/c/6d8685dd9718e0613f7c64253500874021b9efc9
- https://git.kernel.org/stable/c/aba188d6f4ebaf52acf13f204db2bd2c22072504
Get alerted when CVE-2024-46811 or the next vulnerability affects your stack