What’s Vulnerable › Vulnerabilities
CVE-2024-46814: drm/amd/display: Check msg_id before processing transcation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amd/display: Check msg_id before processing transcation [WHY & HOW] HDCP_MESSAGE_ID_INVALID (-1) is not a valid msg_id nor is it a valid array index, and it needs checking before used. This fixes 4 OVERRUN issues reported by Coverity.
Affected products
- Linux kernel: before 5.10.226; from 5.11 before 5.15.167; from 5.16 before 6.1.109; from 6.2 before 6.6.50; from 6.7 before 6.10.9 — fixed in 5.10.226, 5.15.167, 6.1.109, 6.10.9, 6.6.50
How to fix
Upgrade to a fixed version: Linux kernel 5.10.226, 5.15.167, 6.1.109, 6.10.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0147505f08220c89b3a9c90eb608191276e263a8
- https://git.kernel.org/stable/c/6590643c5de74098d27933b7d224d5ac065d7755
- https://git.kernel.org/stable/c/916083054670060023d3f8a8ace895d710e268f4
- https://git.kernel.org/stable/c/cb63090a17d3abb87f132851fa3711281249b7d2
- https://git.kernel.org/stable/c/fa71face755e27dc44bc296416ebdf2c67163316
- https://git.kernel.org/stable/c/fe63daf7b10253b0faaa60c55d6153cd276927aa
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-46814 or the next vulnerability affects your stack