What’s Vulnerable › Vulnerabilities
CVE-2024-46815: drm/amd/display: Check num_valid_sets before accessing reader_wm_sets[]
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amd/display: Check num_valid_sets before accessing reader_wm_sets[] [WHY & HOW] num_valid_sets needs to be checked to avoid a negative index when accessing reader_wm_sets[num_valid_sets - 1]. This fixes an OVERRUN issue reported by Coverity.
Affected products
- Linux kernel: before 5.4.284; from 5.10 before 5.10.226; from 5.11 before 5.15.167; from 5.16 before 6.1.109; from 6.2 before 6.6.50; from 6.7 before 6.10.9 — fixed in 5.10.226, 5.15.167, 5.4.284, 6.1.109, 6.10.9, 6.6.50
How to fix
Upgrade to a fixed version: Linux kernel 5.10.226, 5.15.167, 5.4.284, 6.1.109. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/21f9cb44f8c60bf6c26487d428b1a09ad3e8aebf
- https://git.kernel.org/stable/c/6a4a08e45e614cfa7a56498cdfaeb7fae2f07fa0
- https://git.kernel.org/stable/c/7c47dd2e92341f2989ab73dbed07f8894593ad7b
- https://git.kernel.org/stable/c/a72d4996409569027b4609414a14a87679b12267
- https://git.kernel.org/stable/c/b36e9b3104c4ba0f2f5dd083dcf6159cb316c996
- https://git.kernel.org/stable/c/b38a4815f79b87efb196cd5121579fc51e29a7fb
- https://git.kernel.org/stable/c/c4a7f7c0062fe2c73f70bb7e335199e25bd71492
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-46815 or the next vulnerability affects your stack