What’s Vulnerable › Vulnerabilities
CVE-2024-46817: drm/amd/display: Stop amdgpu_dm initialize when stream nums greater than 6
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amd/display: Stop amdgpu_dm initialize when stream nums greater than 6 [Why] Coverity reports OVERRUN warning. Should abort amdgpu_dm initialize. [How] Return failure to amdgpu_dm_init.
Affected products
- Linux kernel: from 5.4 before 5.4.284; from 5.10 before 5.10.226; from 5.11 before 5.15.167; from 5.16 before 6.1.109; from 6.2 before 6.6.50; from 6.7 before 6.10.9 — fixed in 5.10.226, 5.15.167, 5.4.284, 6.1.109, 6.10.9, 6.6.50
How to fix
Upgrade to a fixed version: Linux kernel 5.10.226, 5.15.167, 5.4.284, 6.1.109. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/21bbb39863f10f5fb4bf772d15b07d5d13590e9d
- https://git.kernel.org/stable/c/28b515c458aa9c92bfcb99884c94713a5f471cea
- https://git.kernel.org/stable/c/754321ed63f0a4a31252ca72e0bd89a9e1888018
- https://git.kernel.org/stable/c/84723eb6068c50610c5c0893980d230d7afa2105
- https://git.kernel.org/stable/c/94cb77700fa4ae6200486bfa0ba2ac547534afd2
- https://git.kernel.org/stable/c/d398c74c881dee695f6eb6138c9891644e1c3d9d
- https://git.kernel.org/stable/c/d619b91d3c4af60ac422f1763ce53d721fb91262
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-46817 or the next vulnerability affects your stack