What’s Vulnerable › Vulnerabilities
CVE-2024-46818: drm/amd/display: Check gpio_id before used as array index
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-08-04
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amd/display: Check gpio_id before used as array index [WHY & HOW] GPIO_ID_UNKNOWN (-1) is not a valid value for array index and therefore should be checked in advance. This fixes 5 OVERRUN issues reported by Coverity.
Affected products
- Linux kernel: before 5.4.284; from 5.5 before 5.10.226; from 5.11 before 5.15.167; from 5.16 before 6.1.109; from 6.2 before 6.6.50; from 6.7 before 6.10.9 — fixed in 5.10.226, 5.15.167, 5.4.284, 6.1.109, 6.10.9, 6.6.50
How to fix
Upgrade to a fixed version: Linux kernel 5.10.226, 5.15.167, 5.4.284, 6.1.109. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0184cca30cad74d88f5c875d4e26999e26325700
- https://git.kernel.org/stable/c/08e7755f754e3d2cef7d3a7da538d33526bd6f7c
- https://git.kernel.org/stable/c/276e3fd93e3beb5894eb1cc8480f9f417d51524d
- https://git.kernel.org/stable/c/2a5626eeb3b5eec7a36886f9556113dd93ec8ed6
- https://git.kernel.org/stable/c/3d4198ab612ad48f73383ad3bb5663e6f0cdf406
- https://git.kernel.org/stable/c/40c2e8bc117cab8bca8814735f28a8b121654a84
- https://git.kernel.org/stable/c/8520fdc8ecc38f240a8e9e7af89cca6739c3e790
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-46818 or the next vulnerability affects your stack