What’s Vulnerable › Vulnerabilities
CVE-2024-46836: usb: gadget: aspeed_udc: validate endpoint index for ast udc
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: usb: gadget: aspeed_udc: validate endpoint index for ast udc We should verify the bound of the array to assure that host may not manipulate the index to point past endpoint array. Found by static analysis.
Affected products
- Linux kernel: before 6.1.110; from 6.2 before 6.6.51; from 6.7 before 6.10.10 — fixed in 6.1.110, 6.10.10, 6.6.51
How to fix
Upgrade to a fixed version: Linux kernel 6.1.110, 6.10.10, 6.6.51. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/31bd4fab49c0adc6228848357c1b1df9395858af
- https://git.kernel.org/stable/c/6fe9ca2ca389114c8da66e534c18273497843e8a
- https://git.kernel.org/stable/c/b2a50ffdd1a079869a62198a8d1441355c513c7c
- https://git.kernel.org/stable/c/ee0d382feb44ec0f445e2ad63786cd7f3f6a8199
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-46836 or the next vulnerability affects your stack