What’s Vulnerable › Vulnerabilities
CVE-2024-46837: drm/panthor: Restrict high priorities on group_create
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: drm/panthor: Restrict high priorities on group_create We were allowing any users to create a high priority group without any permission checks. As a result, this was allowing possible denial of service. We now only allow the DRM master or users with the CAP_SYS_NICE capability to set higher priorities than PANTHOR_GROUP_PRIORITY_MEDIUM. As the sole user of that uAPI lives in Mesa and hardcode a value of MEDIUM [1], this should be safe to do. Additionally, as those checks are performed at the ioctl level, panthor_group_create now only check for priority level validity. [1]https://gitlab.freedesktop.org/mesa/mesa/-/blob/f390835074bdf162a63deb0311d1a6de527f9f89/src/gallium/drivers/panfrost/pan_csf.c#L1038
Affected products
- Linux kernel: from 6.10 before 6.10.10; 6.11-rc1, 6.11-rc2, 6.11-rc3, 6.11-rc4, 6.11-rc5, 6.11-rc6 — fixed in 6.10.10
How to fix
Upgrade to a fixed version: Linux kernel 6.10.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/33eb0344e186a2bcc257c6c5a6e65c1cb42adb4a
- https://git.kernel.org/stable/c/5f7762042f8a5377bd8a32844db353c0311a7369
Get alerted when CVE-2024-46837 or the next vulnerability affects your stack