What’s Vulnerable › Vulnerabilities
CVE-2024-46878
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-23 · updated 2026-06-17
- Weakness: CWE-79
Description
A Cross-Site Scripting (XSS) vulnerability exists in the page parameter of tiki-editpage.php in Tiki version 26.3 and earlier. This vulnerability allows attackers to execute arbitrary JavaScript code via a crafted payload, leading to potential access to sensitive information or unauthorized actions.
Affected products
- Tiki: before 27.1 — fixed in 27.1
How to fix
Upgrade to a fixed version: Tiki 27.1. Check the vendor advisory for mitigations.
References
- https://github.com/ColdFusionX/CVE-2024-46878-TikiCMS-XSS
- https://tiki.org/article514-New-Security-Updates-Released-for-Tiki-27-x-LTS-26-x-and-24-x-LTS-and-Upgrade-is-Strongly-Recommended
- https://tiki.org/tiki-newsletters.php?nlId=8&info=1
- https://github.com/ColdFusionX/CVE-2024-46878-TikiCMS-XSS
Get alerted when CVE-2024-46878 or the next vulnerability affects your stack