What’s Vulnerable › Vulnerabilities
CVE-2024-46901: Apache Subversion: mod_dav_svn denial-of-service via control characters in paths
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Insufficient validation of filenames against control characters in Apache Subversion repositories served via mod_dav_svn allows authenticated users with commit access to commit a corrupted revision, leading to disruption for users of the repository. All versions of Subversion up to and including Subversion 1.14.4 are affected if serving repositories via mod_dav_svn. Users are recommended to upgrade to version 1.14.5, which fixes this issue. Repositories served via other access methods are not affected.
Affected products
- Apache Software Foundation Apache Subversion: before 1.14.5 — fixed in 1.14.5
- Debian Linux: 11.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Subversion 1.14.5. Check the vendor advisory for mitigations.
References
- https://subversion.apache.org/security/CVE-2024-46901-advisory.txt
- https://lists.debian.org/debian-lts-announce/2025/04/msg00023.html
Get alerted when CVE-2024-46901 or the next vulnerability affects your stack