What’s Vulnerable › Vulnerabilities
CVE-2024-46910: Apache Atlas: An authenticated user can perform XSS and potentially impersonate another user
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-13 · updated 2026-06-17
- Weakness: CWE-80
Description
An authenticated user can perform XSS and potentially impersonate another user. This issue affects Apache Atlas versions 2.3.0 and earlier. Users are recommended to upgrade to version 2.4.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Atlas: from 2.0.0 before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Atlas 2.4.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/sqzp34l4cdk21zoq5g31qlsvr7jvb1fy
- http://www.openwall.com/lists/oss-security/2025/02/12/2
Get alerted when CVE-2024-46910 or the next vulnerability affects your stack