What’s Vulnerable › Vulnerabilities
CVE-2024-46911: Apache Roller: Weakness in CSRF protection allows privilege escalation
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-14 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-site Resource Forgery (CSRF), Privilege escalation vulnerability in Apache Roller. On multi-blog/user Roller websites, by default weblog owners are trusted to publish arbitrary weblog content and this combined with a deficiency in Roller's CSRF protections allowed an escalation of privileges attack. This issue affects Apache Roller before 6.1.4. Roller users who run multi-blog/user Roller websites are recommended to upgrade to version 6.1.4, which fixes the issue. Roller 6.1.4 release announcement: https://lists.apache.org/thread/3c3f6rwqptyw6wdc95654fq5vlosqdpw
Affected products
- Apache Software Foundation Apache Roller: from 1.0 before 6.1.4 — fixed in 6.1.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Roller 6.1.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/6m0ghjo9j92qty00t2qb6qf2spds0p5t
- http://www.openwall.com/lists/oss-security/2024/10/12/1
Get alerted when CVE-2024-46911 or the next vulnerability affects your stack