What’s Vulnerable › Vulnerabilities

CVE-2024-46934

Description

Rocket.Chat 6.12.0, 6.11.2, 6.10.5, 6.9.6, 6.8.6, 6.7.8, and earlier is vulnerable to DOM-based Cross-site Scripting (XSS). Attackers may be able to abuse the UpdateOTRAck method to forge a message that contains an XSS payload.

Affected products

How to fix

Upgrade to a fixed version: Rocket.Chat 6.10.6, 6.11.3, 6.7.9, 6.8.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-46934 or the next vulnerability affects your stack