What’s Vulnerable › Vulnerabilities
CVE-2024-46935
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-25 · updated 2026-06-17
Description
Rocket.Chat 6.12.0, 6.11.2, 6.10.5, 6.9.6, 6.8.6, 6.7.8, and earlier is vulnerable to denial of service (DoS). Attackers who craft messages with specific characters may crash the workspace due to an issue in the message parser.
Affected products
- Rocket.Chat: before 6.7.9; from 6.8.0 before 6.8.7; from 6.9.0 before 6.9.7; from 6.10.0 before 6.10.6; from 6.11.0 before 6.11.3; 6.12.0, 6.12.0-rc1, 6.12.0-rc2, 6.12.0-rc3, 6.12.0-rc4, 6.12.0-rc5 (+1) — fixed in 6.10.6, 6.11.3, 6.7.9, 6.8.7, 6.9.7
How to fix
Upgrade to a fixed version: Rocket.Chat 6.10.6, 6.11.3, 6.7.9, 6.8.7. Check the vendor advisory for mitigations.
References
- https://docs.rocket.chat/docs/rocketchat-security-fixes-updates-and-advisories
- https://github.com/RocketChat/Rocket.Chat/pull/33227
Get alerted when CVE-2024-46935 or the next vulnerability affects your stack