What’s Vulnerable › Vulnerabilities
CVE-2024-46936
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-25 · updated 2026-06-17
Description
Rocket.Chat 6.12.0, 6.11.2, 6.10.5, 6.9.6, 6.8.6, 6.7.8, and before is vulnerable to a message forgery / impersonation issue. Attackers can abuse the UpdateOTRAck method to send ephemeral messages as if they were any other user they choose.
Affected products
- RocketChat Rocket.Chat: from 6.12.0 before 6.12.1; from 6.11.0 through 6.11.2; from 6.10.0 through 6.10.5; from 6.9.0 through 6.9.6; from 6.8.0 through 6.8.6; through 6.7.8 — fixed in 6.12.1
How to fix
Upgrade to a fixed version: RocketChat Rocket.Chat 6.12.1. Check the vendor advisory for mitigations.
References
- https://docs.rocket.chat/docs/rocketchat-security-fixes-updates-and-advisories
- https://github.com/RocketChat/Rocket.Chat/pull/33246
Get alerted when CVE-2024-46936 or the next vulnerability affects your stack