What’s Vulnerable › Vulnerabilities
CVE-2024-46952
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-10 · updated 2026-06-17
- Weakness: CWE-120
Description
An issue was discovered in pdf/pdf_xref.c in Artifex Ghostscript before 10.04.0. There is a buffer overflow during handling of a PDF XRef stream (related to W array values).
Affected products
- Artifex Ghostscript: before 10.04.0 — fixed in 10.04.0
- Debian Linux: 12.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 10.04.0. Check the vendor advisory for mitigations.
References
- https://bugs.ghostscript.com/show_bug.cgi?id=708001
- https://cgit.ghostscript.com/cgi-bin/cgit.cgi/ghostpdl.git/commit/?id=b1f0827c30f59a2dcbc8a39e42cace7a1de35f7f
- https://github.com/ArtifexSoftware/ghostpdl/blob/master/doc/News.html
Get alerted when CVE-2024-46952 or the next vulnerability affects your stack