What’s Vulnerable › Vulnerabilities
CVE-2024-46954
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-10 · updated 2026-06-17
- Weakness: CWE-22
Description
An issue was discovered in decode_utf8 in base/gp_utf8.c in Artifex Ghostscript before 10.04.0. Overlong UTF-8 encoding leads to possible ../ directory traversal.
Affected products
- Artifex Ghostscript: before 10.04.0 — fixed in 10.04.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 10.04.0. Check the vendor advisory for mitigations.
References
- https://bugs.ghostscript.com/show_bug.cgi?id=707788
- https://cgit.ghostscript.com/cgi-bin/cgit.cgi/ghostpdl.git/commit/?id=55f587dd039282316f512e1bea64218fd991f934
- https://github.com/ArtifexSoftware/ghostpdl/blob/master/doc/News.html
Get alerted when CVE-2024-46954 or the next vulnerability affects your stack