What’s Vulnerable › Vulnerabilities
CVE-2024-4697: Cowidgets – Elementor Addons <= 1.1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via heading_tag Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Cowidgets – Elementor Addons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘heading_tag’ parameter in all versions up to, and including, 1.1.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. CVE-2024-35782 is likely a duplicate of this issue.
Affected products
- codelessthemes Cowidgets – Elementor Addons: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: codelessthemes Cowidgets – Elementor Addons 1.2.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3099564%40cowidgets-elementor-addons&new=3099564%40cowidgets-elementor-addons&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/beb28e9e-bf6a-4eed-afbc-ca85ec489df7?source=cve
- https://plugins.trac.wordpress.org/browser/cowidgets-elementor-addons/trunk/inc/widgets-manager/widgets/header/class-page-title.php#L418
- https://plugins.trac.wordpress.org/browser/cowidgets-elementor-addons/trunk/inc/widgets-manager/widgets/header/class-site-title.php#L423
- https://www.wordfence.com/threat-intel/vulnerabilities/id/beb28e9e-bf6a-4eed-afbc-ca85ec489df7?source=cve
Get alerted when CVE-2024-4697 or the next vulnerability affects your stack