What’s Vulnerable › Vulnerabilities
CVE-2024-46980: Tuleap vulnerable to XSS in the HTML mail content of the cross reference field
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Tuleap is a tool for end to end traceability of application and system developments. Prior to Tuleap Community Edition 15.13.99.37, Tuleap Enterprise Edition 15.13-3, and Tuleap Enterprise Edition 15.12-6, a site administrator could create an artifact link type with a forward label allowing them to execute uncontrolled code (or at least achieve content injection) in a mail client. Tuleap Community Edition 15.13.99.37, Tuleap Enterprise Edition 15.13-3, and Tuleap Enterprise Edition 15.12-6 fix this issue.
Affected products
- Enalean tuleap: before 15.12-6; before 15.13.99.37; from 15.13-0 before 15.13-3 — fixed in 15.12-6, 15.13-3, 15.13.99.37
How to fix
Upgrade to a fixed version: Enalean tuleap 15.12-6, 15.13-3, 15.13.99.37. Check the vendor advisory for mitigations.
References
- https://github.com/Enalean/tuleap/commit/dd94a799982cd78ab06142008d745edf9e8fd494
- https://github.com/Enalean/tuleap/security/advisories/GHSA-9fc9-47h6-82jj
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=dd94a799982cd78ab06142008d745edf9e8fd494
- https://tuleap.net/plugins/tracker/?aid=39689
Get alerted when CVE-2024-46980 or the next vulnerability affects your stack