What’s Vulnerable › Vulnerabilities
CVE-2024-46981: Redis' Lua library commands may lead to remote code execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-06 · updated 2026-06-17
- Weakness: CWE-416
Description
Redis is an open source, in-memory database that persists on disk. An authenticated user may use a specially crafted Lua script to manipulate the garbage collector and potentially lead to remote code execution. The problem is fixed in 7.4.2, 7.2.7, and 6.2.17. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to restrict EVAL and EVALSHA commands.
Affected products
- Debian Linux: 11.0
- Redis: from 6.2.0 before 6.2.17; from 7.2.0 before 7.2.7; from 7.4.0 before 7.4.2 — fixed in 6.2.17, 7.2.7, 7.4.2
How to fix
Upgrade to a fixed version: Redis 6.2.17, 7.2.7, 7.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/releases/tag/6.2.17
- https://github.com/redis/redis/releases/tag/7.2.7
- https://github.com/redis/redis/releases/tag/7.4.2
- https://github.com/redis/redis/security/advisories/GHSA-39h2-x6c4-6w4c
- https://lists.debian.org/debian-lts-announce/2025/01/msg00018.html
- https://www.vicarius.io/vsociety/posts/cve-2024-46981-detect-redis-vulnerability
- https://www.vicarius.io/vsociety/posts/cve-2024-46981-mitigate-redis-vulnerability
Get alerted when CVE-2024-46981 or the next vulnerability affects your stack