What’s Vulnerable › Vulnerabilities
CVE-2024-46995: baserCMS has Cross-site Scripting Vulnerability in HTTP 400 Bad Request
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-24 · updated 2026-06-17
- Weakness: CWE-79
Description
baserCMS is a website development framework. Versions prior to 5.1.2 have a cross-site scripting vulnerability in HTTP 400 Bad Request. Version 5.1.2 fixes this issue.
Affected products
- baserproject basercms: before 5.1.2 — fixed in 5.1.2
How to fix
Upgrade to a fixed version: baserproject basercms 5.1.2. Check the vendor advisory for mitigations.
References
- https://basercms.net/security/JVN_06274755
- https://github.com/baserproject/basercms/security/advisories/GHSA-mr7q-fv7j-jcgv
Get alerted when CVE-2024-46995 or the next vulnerability affects your stack