What’s Vulnerable › Vulnerabilities
CVE-2024-4700: WP Table Builder – WordPress Table Plugin <= 1.4.14 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Table Builder – WordPress Table Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the button element in all versions up to, and including, 1.4.14 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. By default, this can only be exploited by administrators, but the ability to use and configure WP Table Builder can be extended to contributors.
Affected products
- WP Table Builder: before 1.4.15 — fixed in 1.4.15
How to fix
Upgrade to a fixed version: WP Table Builder 1.4.15. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-table-builder/trunk/inc/admin/element-classes/elements/button-element.php#L343
- https://plugins.trac.wordpress.org/changeset/3088612/
- https://wordpress.org/plugins/wp-table-builder/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/20cd08ac-826f-40dd-804a-546b0c334b66?source=cve
- https://plugins.trac.wordpress.org/browser/wp-table-builder/trunk/inc/admin/element-classes/elements/button-element.php#L343
- https://plugins.trac.wordpress.org/changeset/3088612/
- https://wordpress.org/plugins/wp-table-builder/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/20cd08ac-826f-40dd-804a-546b0c334b66?source=cve
Get alerted when CVE-2024-4700 or the next vulnerability affects your stack