What’s Vulnerable › Vulnerabilities
CVE-2024-4702: Mega Elements <= 1.2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Button Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Mega Elements plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Button widget in all versions up to, and including, 1.2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Kraft Plugins Mega Elements: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: Kraft Plugins Mega Elements 1.2.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3085457/mega-elements-addons-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3808ca2a-e78e-4118-890b-c22a71f8e855?source=cve
- https://plugins.trac.wordpress.org/changeset/3085457/mega-elements-addons-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3808ca2a-e78e-4118-890b-c22a71f8e855?source=cve
Get alerted when CVE-2024-4702 or the next vulnerability affects your stack