What’s Vulnerable › Vulnerabilities
CVE-2024-47049
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-17 · updated 2026-06-17
- Weakness: CWE-22
Description
The czim/file-handling package before 1.5.0 and 2.x before 2.3.0 (used with PHP Composer) does not properly validate URLs within makeFromUrl and makeFromAny, leading to SSRF, and to directory traversal for the reading of local files.
Affected products
- Czim File-Handling: before 1.5.0; from 2.0.0 before 2.3.0 — fixed in 1.5.0, 2.3.0
How to fix
Upgrade to a fixed version: Czim File-Handling 1.5.0, 2.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47049 or the next vulnerability affects your stack