What’s Vulnerable › Vulnerabilities
CVE-2024-47058: Cross-site Scripting (XSS) - stored (edit form HTML field)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-18 · updated 2026-06-17
- Weakness: CWE-79
Description
With access to edit a Mautic form, the attacker can add Cross-Site Scripting stored in the html filed. This could be used to steal sensitive information from the user's current session.
Affected products
- Mautic: from 1.0.0 before 4.4.13; from 5.0.0 before 5.1.1 — fixed in 4.4.13, 5.1.1
How to fix
Upgrade to a fixed version: Mautic 4.4.13, 5.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47058 or the next vulnerability affects your stack