What’s Vulnerable › Vulnerabilities
CVE-2024-47066: Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964)
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-23 · updated 2026-06-17
- Weakness: CWE-918
Description
Lobe Chat is an open-source artificial intelligence chat framework. Prior to version 1.19.13, server-side request forgery protection implemented in `src/app/api/proxy/route.ts` does not consider redirect and could be bypassed when attacker provides an external malicious URL which redirects to internal resources like a private network or loopback address. Version 1.19.13 contains an improved fix for the issue.
Affected products
- lobehub lobe-chat: before 1.19.3 — fixed in 1.19.3
How to fix
Upgrade to a fixed version: lobehub lobe-chat 1.19.3. Check the vendor advisory for mitigations.
References
- https://github.com/lobehub/lobe-chat/blob/main/src/app/api/proxy/route.ts
- https://github.com/lobehub/lobe-chat/commit/e960a23b0c69a5762eb27d776d33dac443058faf
- https://github.com/lobehub/lobe-chat/security/advisories/GHSA-3fc8-2r3f-8wrg
- https://github.com/lobehub/lobe-chat/security/advisories/GHSA-mxhq-xw3g-rphc
Get alerted when CVE-2024-47066 or the next vulnerability affects your stack