What’s Vulnerable › Vulnerabilities
CVE-2024-47067: Alist Contains a Reflected Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-30 · updated 2026-06-17
- Weakness: CWE-79
Description
AList is a file list program that supports multiple storages. AList contains a reflected cross-site scripting vulnerability in helper.go. The endpoint /i/:link_name takes in a user-provided value and reflects it back in the response. The endpoint returns an application/xml response, opening it up to HTML tags via XHTML and thus leading to a XSS vulnerability. This vulnerability is fixed in 3.29.0.
Affected products
- AlistGo alist: before 3.29.0 — fixed in 3.29.0
How to fix
Upgrade to a fixed version: AlistGo alist 3.29.0. Check the vendor advisory for mitigations.
References
- https://github.com/alist-org/alist/commit/6100647310594868e931f3de1188ddd8bde93b78
- https://securitylab.github.com/advisories/GHSL-2023-220_Alist/
Get alerted when CVE-2024-47067 or the next vulnerability affects your stack