What’s Vulnerable › Vulnerabilities

CVE-2024-47068: DOM Clobbering Gadget found in rollup bundled scripts that leads to XSS

Description

Rollup is a module bundler for JavaScript. Versions prior to 2.79.2, 3.29.5, and 4.22.4 are susceptible to a DOM Clobbering vulnerability when bundling scripts with properties from `import.meta` (e.g., `import.meta.url`) in `cjs`/`umd`/`iife` format. The DOM Clobbering gadget can lead to cross-site scripting (XSS) in web pages where scriptless attacker-controlled HTML elements (e.g., an `img` tag with an unsanitized `name` attribute) are present. Versions 2.79.2, 3.29.5, and 4.22.4 contain a patch for the vulnerability.

Affected products

How to fix

Upgrade to a fixed version: rollup 2.79.2, 3.29.5, 4.22.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-47068 or the next vulnerability affects your stack