What’s Vulnerable › Vulnerabilities
CVE-2024-47070: authentik vulnerable to password authentication bypass via X-Forwarded-For HTTP header
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-287
Description
authentik is an open-source identity provider. A vulnerability that exists in versions prior to 2024.8.3 and 2024.6.5 allows bypassing password login by adding X-Forwarded-For header with an unparsable IP address, e.g. `a`. This results in a possibility of logging into any account with a known login or email address. The vulnerability requires the authentik instance to trust X-Forwarded-For header provided by the attacker, thus it is not reproducible from external hosts on a properly configured environment. The issue occurs due to the password stage having a policy bound to it, which skips the password stage if the Identification stage is setup to also contain a password stage. Due to the invalid X-Forwarded-For header, which does not get validated to be an IP Address early enough, the exception happens later and the policy fails. The default blueprint doesn't correctly set `failure_result` to `True` on the policy binding meaning that due to this exception the policy returns false and the password stage is skipped. Versions 2024.8.3 and 2024.6.5 fix this issue.
Affected products
- goauthentik authentik: before 2024.6.5; from 2024.8.0 before 2024.8.3 — fixed in 2024.6.5, 2024.8.3
How to fix
Upgrade to a fixed version: goauthentik authentik 2024.6.5, 2024.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/goauthentik/authentik/commit/78f7b04d5a62b2a9d4316282a713c2c7857dbe29
- https://github.com/goauthentik/authentik/commit/dd8f809161e738b25765797eb2a5c77a7d3fc2cf
- https://github.com/goauthentik/authentik/security/advisories/GHSA-7jxf-mmg9-9hg7
Get alerted when CVE-2024-47070 or the next vulnerability affects your stack