What’s Vulnerable › Vulnerabilities
CVE-2024-47073: Dataease arbitrary interface access vulnerability
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-07 · updated 2026-06-17
- Weakness: CWE-347
Description
DataEase is an open source data visualization analysis tool that helps users quickly analyze data and gain insights into business trends. In affected versions a the lack of signature verification of jwt tokens allows attackers to forge jwts which then allow access to any interface. The vulnerability has been fixed in v2.10.2 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- dataease: before 2.10.2 — fixed in 2.10.2
How to fix
Upgrade to a fixed version: dataease 2.10.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47073 or the next vulnerability affects your stack