What’s Vulnerable › Vulnerabilities
CVE-2024-47074: Dataease PostgreSQL Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-11 · updated 2026-06-17
- Weakness: CWE-502
Description
DataEase is an open source data visualization analysis tool. In Dataease, the PostgreSQL data source in the data source function can customize the JDBC connection parameters and the PG server target to be connected. In backend/src/main/java/io/dataease/provider/datasource/JdbcProvider.java, PgConfiguration class don't filter any parameters, directly concat user input. So, if the attacker adds some parameters in JDBC url, and connect to evil PG server, the attacker can trigger the PG jdbc deserialization vulnerability, and eventually the attacker can execute through the deserialization vulnerability system commands and obtain server privileges. The vulnerability has been fixed in v1.18.25.
Affected products
- dataease: before 1.18.25 — fixed in 1.18.25
How to fix
Upgrade to a fixed version: dataease 1.18.25. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/commit/86eafc4d77f0bbc0eaa7fc58e5076a085257f259
- https://github.com/dataease/dataease/security/advisories/GHSA-jgg7-w629-wcpc
Get alerted when CVE-2024-47074 or the next vulnerability affects your stack