What’s Vulnerable › Vulnerabilities
CVE-2024-47081: Requests vulnerable to .netrc credentials leak via malicious URLs
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-09 · updated 2026-06-17
- Weakness: CWE-522
Description
Requests is a HTTP library. Due to a URL parsing issue, Requests releases prior to 2.32.4 may leak .netrc credentials to third parties for specific maliciously-crafted URLs. Users should upgrade to version 2.32.4 to receive a fix. For older versions of Requests, use of the .netrc file can be disabled with `trust_env=False` on one's Requests Session.
Affected products
- Pypi Requests: before 2.32.4; 0.0.1, 0.10.0, 0.10.1, 0.10.2, 0.10.3, 0.10.4 (+149) — fixed in 2.32.4
- psf requests: before 2.32.4
How to fix
Upgrade to a fixed version: Pypi Requests 2.32.4. Check the vendor advisory for mitigations.
References
- https://github.com/psf/requests/commit/96ba401c1296ab1dda74a2365ef36d88f7d144ef
- https://github.com/psf/requests/pull/6965
- https://github.com/psf/requests/security/advisories/GHSA-9hjg-9r4m-mvj7
- https://requests.readthedocs.io/en/latest/api/#requests.Session.trust_env
- https://seclists.org/fulldisclosure/2025/Jun/2
- http://seclists.org/fulldisclosure/2025/Jun/2
- http://www.openwall.com/lists/oss-security/2025/06/03/11
- http://www.openwall.com/lists/oss-security/2025/06/03/9
- http://www.openwall.com/lists/oss-security/2025/06/04/1
- http://www.openwall.com/lists/oss-security/2025/06/04/6
Get alerted when CVE-2024-47081 or the next vulnerability affects your stack